View Issue Details

IDProjectCategoryView StatusLast Update
0003905SymmetricDSBugpublic2019-05-08 10:59
Reporterj.mackay@backinmotion.com.auAssigned Toelong 
Priorityurgent 
Status closedResolutionfixed 
Product Version3.10.0 
Target Version3.10.1Fixed in Version3.10.1 
Summary0003905: Table sym_extract_request not found when using different prefix
DescriptionOur symmetric tables use a prefix "P001_sym_extract_request" etc. But the logs aren't using the prefix.

Additional InformationFailed to execute EXTRACT for node Merge and channel default StackTraceKey.init [SqlException:3735487048]
org.jumpmind.db.sql.SqlException: Invalid object name 'sym_extract_request'.
    at org.jumpmind.db.sql.AbstractSqlTemplate.translate(AbstractSqlTemplate.java:302)
    at org.jumpmind.db.sql.AbstractSqlTemplate.translate(AbstractSqlTemplate.java:291)
    at org.jumpmind.db.sql.JdbcSqlTemplate.execute(JdbcSqlTemplate.java:513)
    at org.jumpmind.db.sql.JdbcSqlTemplate.queryForObject(JdbcSqlTemplate.java:166)
    at org.jumpmind.db.sql.AbstractSqlTemplate.queryForInt(AbstractSqlTemplate.java:63)
    at org.jumpmind.symmetric.service.impl.DataExtractorService.releaseMissedExtractRequests(DataExtractorService.java:2221)
    at org.jumpmind.symmetric.service.impl.DataExtractorService.execute(DataExtractorService.java:2118)
    at org.jumpmind.symmetric.service.impl.NodeCommunicationService$1.run(NodeCommunicationService.java:519)
    at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)
    at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
    at java.lang.Thread.run(Unknown Source)
Caused by: com.microsoft.sqlserver.jdbc.SQLServerException: Invalid object name 'sym_extract_request'.
    at com.microsoft.sqlserver.jdbc.SQLServerException.makeFromDatabaseError(SQLServerException.java:256)
    at com.microsoft.sqlserver.jdbc.SQLServerStatement.getNextResult(SQLServerStatement.java:1621)
    at com.microsoft.sqlserver.jdbc.SQLServerPreparedStatement.doExecutePreparedStatement(SQLServerPreparedStatement.java:592)
    at com.microsoft.sqlserver.jdbc.SQLServerPreparedStatement$PrepStmtExecCmd.doExecute(SQLServerPreparedStatement.java:522)
    at com.microsoft.sqlserver.jdbc.TDSCommand.execute(IOBuffer.java:7194)
    at com.microsoft.sqlserver.jdbc.SQLServerConnection.executeCommand(SQLServerConnection.java:2930)
    at com.microsoft.sqlserver.jdbc.SQLServerStatement.executeCommand(SQLServerStatement.java:248)
    at com.microsoft.sqlserver.jdbc.SQLServerStatement.executeStatement(SQLServerStatement.java:223)
    at com.microsoft.sqlserver.jdbc.SQLServerPreparedStatement.executeQuery(SQLServerPreparedStatement.java:444)
    at org.apache.commons.dbcp.DelegatingPreparedStatement.executeQuery(DelegatingPreparedStatement.java:96)
    at org.apache.commons.dbcp.DelegatingPreparedStatement.executeQuery(DelegatingPreparedStatement.java:96)
    at org.jumpmind.db.sql.JdbcSqlTemplate$1.execute(JdbcSqlTemplate.java:178)
    at org.jumpmind.db.sql.JdbcSqlTemplate.execute(JdbcSqlTemplate.java:511)
    ... 8 more
TagsNo tags attached.

Activities

There are no notes attached to this issue.

Related Changesets

SymmetricDS: 3.10 580bf327

2019-04-09 08:26:56

admin

Details Diff
0003905: table sym_extract_request not found, missing table prefix
0003905
mod - symmetric-core/src/main/java/org/jumpmind/symmetric/service/impl/DataExtractorServiceSqlMap.java Diff File

Issue History

Date Modified Username Field Change
2019-04-08 20:41 j.mackay@backinmotion.com.au New Issue
2019-04-09 08:27 elong Assigned To => elong
2019-04-09 08:27 elong Status new => assigned
2019-04-09 08:28 elong Status assigned => resolved
2019-04-09 08:28 elong Resolution open => fixed
2019-04-09 08:28 elong Fixed in Version => 3.10.1
2019-04-09 08:28 admin Target Version => 3.10.1
2019-04-09 09:00 admin Changeset attached => SymmetricDS 3.10 580bf327
2019-04-23 11:41 elong Status resolved => closed
2019-05-08 10:59 admin Summary MSSQL: table sym_extract_request not found. => Table sym_extract_request not found when using different prefix