View Issue Details

IDProjectCategoryView StatusLast Update
0004294SymmetricDSBugpublic2020-03-04 13:13
ReporterchensonAssigned Tochenson 
Prioritynormal 
Status closedResolutionfixed 
Product Version3.11.5 
Target Version3.11.6Fixed in Version3.11.6 
Summary0004294: Primary key are dropped and created continuously
DescriptionThis was observed on postgresql. If the order of primary key columns in a Table.java object change, but the columns that make up the primary remain the same, SymmetricDS will detect a primary key change and drop and recreate the primary key with the new order. However, when the Table is read from the database the primary key will be represented by the previous order because the list of pk columns are returned in the order that the columns were create, not in the order that the new primary key represents. This means that the change will be detected again and again.

This initial fix is to ignore the order of the primary key columns when detecting primary key changes. The long term fix should be to represent the primary key order correctly in the Table.java class.
TagsNo tags attached.

Relationships

related to 0004295 new Detect when the order of a primary key changes in order to regenerate it 

Activities

There are no notes attached to this issue.

Issue History

Date Modified Username Field Change
2020-02-28 15:57 chenson New Issue
2020-02-28 15:57 chenson Status new => assigned
2020-02-28 15:57 chenson Assigned To => chenson
2020-02-28 16:01 chenson Status assigned => confirmed
2020-03-02 11:13 elong Relationship added related to 0004295
2020-03-02 11:13 elong Status confirmed => resolved
2020-03-02 11:13 elong Resolution open => fixed
2020-03-02 11:13 elong Fixed in Version => 3.11.6
2020-03-04 13:13 chenson Status resolved => closed