View Issue Details

IDProjectCategoryView StatusLast Update
0004304SymmetricDSBugpublic2020-03-17 14:43
Reporterpmarzullo Assigned Topmarzullo  
Prioritynormal 
Status closedResolutionfixed 
Product Version3.11.5 
Target Version3.11.7Fixed in Version3.11.7 
Summary0004304: MySql and MariaDB: Streaming row mode does not call concat() on primary keys for insert and update reload triggers
DescriptionStreaming mode
insertReloadTriggerTemplate
updateReloadTriggerTemplate

Need to concatenate newKeys and oldKeys, especially when more than one column is used for primary key.

Also, the updateReloadTriggerTemplate concatenates the old and new columns, but they are not used because we are only capturing primary keys (for streaming mode).
Need to remove those calls.
Steps To Reproduce1. Turn on streaming mode
2. Sync a table that has more than one column set up for primary key.
Tagsdialect: mysql/mariadb

Activities

There are no notes attached to this issue.

Related Changesets

SymmetricDS: 3.11 c636d301

2020-03-09 12:25:56

Philip Marzullo

Details Diff
0004304: MySql and MariaDB: Streaming row mode does not call concat() on
primary keys for insert and update reload triggers
Affected Issues
0004304
mod - symmetric-client/src/main/java/org/jumpmind/symmetric/db/mysql/MySqlTriggerTemplate.java Diff File

Issue History

Date Modified Username Field Change
2020-03-09 12:20 pmarzullo New Issue
2020-03-09 12:20 pmarzullo Status new => assigned
2020-03-09 12:20 pmarzullo Assigned To => pmarzullo
2020-03-09 12:20 pmarzullo Tag Attached: dialect: mysql/mariadb
2020-03-09 12:23 pmarzullo Product Version 3.10.10 => 3.11.5
2020-03-09 12:23 pmarzullo Target Version 3.10.11 => 3.11.7
2020-03-09 12:36 pmarzullo Status assigned => resolved
2020-03-09 12:36 pmarzullo Resolution open => fixed
2020-03-09 12:36 pmarzullo Fixed in Version => 3.11.7
2020-03-09 13:00 Changeset attached => SymmetricDS 3.11 c636d301
2020-03-17 14:43 admin Status resolved => closed