View Issue Details

IDProjectCategoryView StatusLast Update
0004405SymmetricDSBugpublic2020-05-26 12:37
ReporterpmarzulloAssigned Topmarzullo 
Prioritynormal 
Status closedResolutionfixed 
Product Version3.11.8 
Target Version3.11.9Fixed in Version3.11.9 
Summary0004405: Initial Load: Retrieve active trigger histories after retrieving Sync Trigger lock
DescriptionThe initial load request processing is meant to acquire a Sync Triggers lock before processing an initial load request.

When a new node is created, one of the things that occurs is to run the Sync Triggers functionality.
Before that is done, an initial load request may be requested, and started to process.
During the process, the list of active trigger histories is retrieved from the database.
This retrieval is done before acquiring the Sync Triggers lock.
That means that the list of active trigger histories may be incomplete, because the Sync Triggers functionality is currently running.

This makes the initial load processing incomplete because it does not know about all of the trigger history records.
Steps To Reproduce1. Create a new node
2. Make sure that sync triggers is running.
3. Request an initial load for the new node.
4. Processing of that initial load request should start to be processed before the sync triggers is complete.
5. List of tables that reload events are created for is incomplete.
Additional InformationFix is to calculate the active trigger histories after pulling the Sync Triggers lock.
Tagsinitial/partial load

Activities

There are no notes attached to this issue.

Issue History

Date Modified Username Field Change
2020-05-22 10:43 pmarzullo New Issue
2020-05-22 10:43 pmarzullo Status new => assigned
2020-05-22 10:43 pmarzullo Assigned To => pmarzullo
2020-05-22 10:43 pmarzullo Tag Attached: initial/partial load
2020-05-22 10:46 pmarzullo Status assigned => resolved
2020-05-22 10:46 pmarzullo Resolution open => fixed
2020-05-22 10:46 pmarzullo Fixed in Version => 3.11.9
2020-05-22 13:02 elong Target Version => 3.11.9
2020-05-26 12:37 elong Status resolved => closed