View Issue Details

IDProjectCategoryView StatusLast Update
0004552SymmetricDSBugpublic2021-03-31 13:00
Reporterpmarzullo Assigned Topmarzullo  
Prioritynormal 
Status closedResolutionfixed 
Product Version3.11.11 
Target Version3.11.12Fixed in Version3.11.12 
Summary0004552: Transforms break deletes when transforming primary key column and not capturing old data as specified in trigger
DescriptionWhen a trigger is set up to not capture old data, and a transform is created that transforms a primary key column, the value of the primary key column ends up being null instead of the value that the transform set it to because the transforms set the value to the old value of a NewAndOldValue object.
Then the TransformWriter takes that old value from the NewAndOldValue object ignores it because there are no oldSourceValues because the trigger did not capture old data.
Steps To Reproduce1. Set up trigger to not capture old data.
2. Set up transform, with a primary key set to a "bsh" type of transform, with the expression set to "return currentValue;".
3. Cause a delete to be captured.
4. Target record will not be deleted.

The staging file should have a null value for the primary key value.
Tagstransformation

Relationships

related to 0004553 closedpmarzullo Transforms break deletes when transforming primary key column and not capturing old data as specified in trigger 
related to 0004932 resolvedpmarzullo Transforms break deletes when primary key columns are transformed because of issue 4552 

Activities

There are no notes attached to this issue.

Related Changesets

SymmetricDS: 3.11 4a598cb9

2020-09-16 16:36:59

pmarzullo

Details Diff
0004552: Transforms break deletes when transforming primary key column
and not capturing old data as specified in trigger
Affected Issues
0004552
mod - symmetric-core/src/main/java/org/jumpmind/symmetric/io/data/transform/BshColumnTransform.java Diff File
mod - symmetric-core/src/main/java/org/jumpmind/symmetric/io/data/transform/LookupColumnTransform.java Diff File
mod - symmetric-core/src/main/java/org/jumpmind/symmetric/io/data/transform/ParameterColumnTransform.java Diff File
mod - symmetric-core/src/main/java/org/jumpmind/symmetric/io/data/transform/VariableColumnTransform.java Diff File
mod - symmetric-io/src/integrationTest/java/org/jumpmind/symmetric/io/data/writer/TransformWriterTest.java Diff File
mod - symmetric-io/src/main/java/org/jumpmind/symmetric/io/data/transform/BinaryLeftColumnTransform.java Diff File
mod - symmetric-io/src/main/java/org/jumpmind/symmetric/io/data/transform/ClarionDateTimeColumnTransform.java Diff File
mod - symmetric-io/src/main/java/org/jumpmind/symmetric/io/data/transform/ConstantColumnTransform.java Diff File
mod - symmetric-io/src/main/java/org/jumpmind/symmetric/io/data/transform/IsNullTransform.java Diff File
mod - symmetric-io/src/main/java/org/jumpmind/symmetric/io/data/transform/LeftColumnTransform.java Diff File
mod - symmetric-io/src/main/java/org/jumpmind/symmetric/io/data/transform/MathColumnTransform.java Diff File
mod - symmetric-io/src/main/java/org/jumpmind/symmetric/io/data/transform/SubstrColumnTransform.java Diff File

SymmetricDS: 3.12 b1d18960

2020-09-16 16:36:59

pmarzullo

Details Diff
0004552: Transforms break deletes when transforming primary key column
and not capturing old data as specified in trigger
Affected Issues
0004552
mod - symmetric-core/src/main/java/org/jumpmind/symmetric/io/data/transform/BshColumnTransform.java Diff File
mod - symmetric-core/src/main/java/org/jumpmind/symmetric/io/data/transform/LookupColumnTransform.java Diff File
mod - symmetric-core/src/main/java/org/jumpmind/symmetric/io/data/transform/ParameterColumnTransform.java Diff File
mod - symmetric-core/src/main/java/org/jumpmind/symmetric/io/data/transform/VariableColumnTransform.java Diff File
mod - symmetric-io/src/integrationTest/java/org/jumpmind/symmetric/io/data/writer/TransformWriterTest.java Diff File
mod - symmetric-io/src/main/java/org/jumpmind/symmetric/io/data/transform/BinaryLeftColumnTransform.java Diff File
mod - symmetric-io/src/main/java/org/jumpmind/symmetric/io/data/transform/ClarionDateTimeColumnTransform.java Diff File
mod - symmetric-io/src/main/java/org/jumpmind/symmetric/io/data/transform/ConstantColumnTransform.java Diff File
mod - symmetric-io/src/main/java/org/jumpmind/symmetric/io/data/transform/IsNullTransform.java Diff File
mod - symmetric-io/src/main/java/org/jumpmind/symmetric/io/data/transform/LeftColumnTransform.java Diff File
mod - symmetric-io/src/main/java/org/jumpmind/symmetric/io/data/transform/MathColumnTransform.java Diff File
mod - symmetric-io/src/main/java/org/jumpmind/symmetric/io/data/transform/SubstrColumnTransform.java Diff File

SymmetricDS: 3.11 4e73dcb6

2021-03-31 12:48:14

pmarzullo

Details Diff
0004932: Transforms break deletes when primary key columns are
transformed because of issue 4552
Affected Issues
0004552, 0004932
mod - symmetric-core/src/main/java/org/jumpmind/symmetric/io/data/transform/BshColumnTransform.java Diff File
mod - symmetric-core/src/main/java/org/jumpmind/symmetric/io/data/transform/LookupColumnTransform.java Diff File
mod - symmetric-core/src/main/java/org/jumpmind/symmetric/io/data/transform/ParameterColumnTransform.java Diff File
mod - symmetric-core/src/main/java/org/jumpmind/symmetric/io/data/transform/VariableColumnTransform.java Diff File
mod - symmetric-io/src/main/java/org/jumpmind/symmetric/io/data/transform/BinaryLeftColumnTransform.java Diff File
mod - symmetric-io/src/main/java/org/jumpmind/symmetric/io/data/transform/ClarionDateTimeColumnTransform.java Diff File
mod - symmetric-io/src/main/java/org/jumpmind/symmetric/io/data/transform/ConstantColumnTransform.java Diff File
mod - symmetric-io/src/main/java/org/jumpmind/symmetric/io/data/transform/IsNullTransform.java Diff File
mod - symmetric-io/src/main/java/org/jumpmind/symmetric/io/data/transform/LeftColumnTransform.java Diff File
mod - symmetric-io/src/main/java/org/jumpmind/symmetric/io/data/transform/MathColumnTransform.java Diff File
mod - symmetric-io/src/main/java/org/jumpmind/symmetric/io/data/transform/SubstrColumnTransform.java Diff File
mod - symmetric-io/src/main/java/org/jumpmind/symmetric/io/data/transform/ValueMapColumnTransform.java Diff File

SymmetricDS: 3.12 7f44877c

2021-03-31 12:48:14

pmarzullo

Details Diff
0004932: Transforms break deletes when primary key columns are
transformed because of issue 4552
Affected Issues
0004552, 0004932
mod - symmetric-core/src/main/java/org/jumpmind/symmetric/io/data/transform/BshColumnTransform.java Diff File
mod - symmetric-core/src/main/java/org/jumpmind/symmetric/io/data/transform/LookupColumnTransform.java Diff File
mod - symmetric-core/src/main/java/org/jumpmind/symmetric/io/data/transform/ParameterColumnTransform.java Diff File
mod - symmetric-core/src/main/java/org/jumpmind/symmetric/io/data/transform/VariableColumnTransform.java Diff File
mod - symmetric-io/src/main/java/org/jumpmind/symmetric/io/data/transform/BinaryLeftColumnTransform.java Diff File
mod - symmetric-io/src/main/java/org/jumpmind/symmetric/io/data/transform/ClarionDateTimeColumnTransform.java Diff File
mod - symmetric-io/src/main/java/org/jumpmind/symmetric/io/data/transform/ConstantColumnTransform.java Diff File
mod - symmetric-io/src/main/java/org/jumpmind/symmetric/io/data/transform/IsNullTransform.java Diff File
mod - symmetric-io/src/main/java/org/jumpmind/symmetric/io/data/transform/LeftColumnTransform.java Diff File
mod - symmetric-io/src/main/java/org/jumpmind/symmetric/io/data/transform/MathColumnTransform.java Diff File
mod - symmetric-io/src/main/java/org/jumpmind/symmetric/io/data/transform/SubstrColumnTransform.java Diff File
mod - symmetric-io/src/main/java/org/jumpmind/symmetric/io/data/transform/ValueMapColumnTransform.java Diff File

Issue History

Date Modified Username Field Change
2020-09-16 20:32 pmarzullo New Issue
2020-09-16 20:32 pmarzullo Status new => assigned
2020-09-16 20:32 pmarzullo Assigned To => pmarzullo
2020-09-16 20:32 pmarzullo Tag Attached: transformation
2020-09-16 20:41 pmarzullo Status assigned => resolved
2020-09-16 20:41 pmarzullo Resolution open => fixed
2020-09-16 20:41 pmarzullo Fixed in Version => 3.11.12
2020-09-16 20:43 pmarzullo Relationship added related to 0004553
2020-09-16 21:00 pmarzullo Changeset attached => SymmetricDS 3.11 4a598cb9
2020-09-16 21:00 pmarzullo Changeset attached => SymmetricDS 3.12 b1d18960
2020-09-23 20:34 admin Status resolved => closed
2021-03-31 12:46 pmarzullo Relationship added related to 0004932
2021-03-31 13:00 pmarzullo Changeset attached => SymmetricDS 3.11 4e73dcb6
2021-03-31 13:00 pmarzullo Changeset attached => SymmetricDS 3.12 7f44877c