View Issue Details

IDProjectCategoryView StatusLast Update
0004714SymmetricDSImprovementpublic2020-12-22 20:00
Reporterelong Assigned Toelong  
Prioritynormal 
Status resolvedResolutionfixed 
Product Version3.11.11 
Target Version3.11.14Fixed in Version3.11.14 
Summary0004714: Oracle fails to check compatible v$parameter
DescriptionOn startup for Oracle 12, it checks the compatibility parameter to see if Oracle is configured to behave like an older version. It tries to access the v$parameter view, but most users don't have access to it. Instead we should use dbms_utility.db_version, which has been around since Oracle 9i and is available to execute by role PUBLIC.

ERROR [client-9995] [JdbcDatabasePlatformFactory] [symmetric-engine-startup-1] Failed to check Oracle compatible parameter StackTraceKey.init [SQLSyntaxErrorException:1901861634] java.sql.SQLSyntaxErrorException: ORA-00942: table or view does not exist

    at oracle.jdbc.driver.T4CTTIoer11.processError(T4CTTIoer11.java:494)
    at oracle.jdbc.driver.T4CTTIoer11.processError(T4CTTIoer11.java:446)
    at oracle.jdbc.driver.T4C8Oall.processError(T4C8Oall.java:1052)
    at oracle.jdbc.driver.T4CTTIfun.receive(T4CTTIfun.java:537)
    at oracle.jdbc.driver.T4CTTIfun.doRPC(T4CTTIfun.java:255)
    at oracle.jdbc.driver.T4C8Oall.doOALL(T4C8Oall.java:610)
    at oracle.jdbc.driver.T4CStatement.doOall8(T4CStatement.java:213)
    at oracle.jdbc.driver.T4CStatement.doOall8(T4CStatement.java:37)
    at oracle.jdbc.driver.T4CStatement.executeForDescribe(T4CStatement.java:724)
    at oracle.jdbc.driver.OracleStatement.executeMaybeDescribe(OracleStatement.java:921)
    at oracle.jdbc.driver.OracleStatement.doExecuteWithTimeout(OracleStatement.java:1099)
    at oracle.jdbc.driver.OracleStatement.executeQuery(OracleStatement.java:1293)
    at oracle.jdbc.driver.OracleStatementWrapper.executeQuery(OracleStatementWrapper.java:366)
    at org.apache.commons.dbcp.DelegatingStatement.executeQuery(DelegatingStatement.java:208)
    at org.apache.commons.dbcp.DelegatingStatement.executeQuery(DelegatingStatement.java:208)
    at org.jumpmind.db.platform.JdbcDatabasePlatformFactory.isOracle122Compatible(JdbcDatabasePlatformFactory.java:451)
    at org.jumpmind.db.platform.JdbcDatabasePlatformFactory.determineDatabaseNameVersionSubprotocol(JdbcDatabasePlatformFactory.java:296)
    at org.jumpmind.db.platform.JdbcDatabasePlatformFactory.createNewPlatformInstance(JdbcDatabasePlatformFactory.java:183)
    at org.jumpmind.symmetric.ClientSymmetricEngine.createDatabasePlatform(ClientSymmetricEngine.java:396)
    at org.jumpmind.symmetric.ClientSymmetricEngine.createDatabasePlatform(ClientSymmetricEngine.java:341)
    at org.jumpmind.symmetric.ClientSymmetricEngine.createDatabasePlatform(ClientSymmetricEngine.java:334)
    at org.jumpmind.symmetric.AbstractSymmetricEngine.init(AbstractSymmetricEngine.java:316)
    at org.jumpmind.symmetric.ClientSymmetricEngine.init(ClientSymmetricEngine.java:205)
    at org.jumpmind.symmetric.web.ServerSymmetricEngine.init(ServerSymmetricEngine.java:80)
    at org.jumpmind.symmetric.ClientSymmetricEngine.<init>(ClientSymmetricEngine.java:161)
    at org.jumpmind.symmetric.web.ServerSymmetricEngine.<init>(ServerSymmetricEngine.java:59)
    at org.jumpmind.symmetric.web.SymmetricEngineHolder.create(SymmetricEngineHolder.java:293)
    at org.jumpmind.symmetric.web.SymmetricEngineHolder$EngineStarter.run(SymmetricEngineHolder.java:605)
    at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149)
    at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624)
    at java.lang.Thread.run(Thread.java:748)
Caused by: Error : 942, Position : 18, Sql = select value from v$parameter where name = 'compatible', OriginalSql = select value from v$parameter where name = 'compatible', Error Msg = ORA-00942: table or view does not exist
    at oracle.jdbc.driver.T4CTTIoer11.processError(T4CTTIoer11.java:498)
    ... 30 more
Tagsdialect: oracle

Relationships

related to 0004461 closedelong Oracle failed to create trigger, identifier is too long 
related to 0004715 closedelong Oracle fails to check compatible v$parameter 

Activities

There are no notes attached to this issue.

Related Changesets

SymmetricDS: 3.11 c91a588f

2020-12-22 19:11:24

admin

Details Diff
0004714: Oracle fails to check compatible v$parameter Affected Issues
0004714
mod - symmetric-jdbc/src/main/java/org/jumpmind/db/platform/JdbcDatabasePlatformFactory.java Diff File

SymmetricDS: 3.12 9867c7ff

2020-12-22 19:11:24

admin

Details Diff
0004714: Oracle fails to check compatible v$parameter Affected Issues
0004714
mod - symmetric-jdbc/src/main/java/org/jumpmind/db/platform/JdbcDatabasePlatformFactory.java Diff File

Issue History

Date Modified Username Field Change
2020-12-22 18:59 elong New Issue
2020-12-22 18:59 elong Status new => assigned
2020-12-22 18:59 elong Assigned To => elong
2020-12-22 18:59 elong Tag Attached: dialect: oracle
2020-12-22 19:08 elong Relationship added related to 0004461
2020-12-22 19:11 elong Status assigned => resolved
2020-12-22 19:11 elong Resolution open => fixed
2020-12-22 19:11 elong Fixed in Version => 3.11.14
2020-12-22 19:12 elong Issue cloned: 0004715
2020-12-22 19:12 elong Relationship added related to 0004715
2020-12-22 20:00 admin Changeset attached => SymmetricDS 3.11 c91a588f
2020-12-22 20:00 admin Changeset attached => SymmetricDS 3.12 9867c7ff