View Issue Details

IDProjectCategoryView StatusLast Update
0004720SymmetricDSBugpublic2021-01-11 13:47
Reporterpmarzullo Assigned Topmarzullo  
Prioritynormal 
Status closedResolutionfixed 
Product Version3.12.5 
Target Version3.12.6Fixed in Version3.12.6 
Summary0004720: MultiBatchStagingWriter writes "\r\n" on Windows for end of lines in child batch staging files
DescriptionMultiBatchStagingWriter, when modifying extracted batch file for child initial load requests, is using System.lineSeparator() to write end of lines.
The problem is that when there is a value that has an embedded newline in it, and that newline is just a "\n" character, and SymmetricDS is running on Windows, the System.lineSeparator() writes out "\r\n", changing the value that is saved in the target database.

Rewrite the reading/parsing/writing logic to only write a "\n" for end of lines, since that is what AbstractProtocolDataWriter uses for end of lines.
Steps To Reproduce1. Have a table that has a value with an embedded new line.
2. Create initial load requests for two nodes at the same for that table, where SymmetricDS is running on a Windows box.
3. Values in the target for one of those nodes will end up having the embedded new line replaced with a "\r\n".
Tagsstaging

Relationships

related to 0004719 resolvedpmarzullo MultiBatchStagingWriter writes "\r\n" on Windows for end of lines in child batch staging files 

Activities

There are no notes attached to this issue.

Issue History

Date Modified Username Field Change
2020-12-23 19:42 pmarzullo New Issue
2020-12-23 19:42 pmarzullo Status new => assigned
2020-12-23 19:42 pmarzullo Assigned To => pmarzullo
2020-12-23 19:42 pmarzullo Tag Attached: staging
2020-12-23 19:43 pmarzullo Relationship added related to 0004719
2020-12-23 21:15 pmarzullo Status assigned => resolved
2020-12-23 21:15 pmarzullo Resolution open => fixed
2020-12-23 21:15 pmarzullo Fixed in Version => 3.12.6
2021-01-11 13:47 admin Status resolved => closed