View Issue Details

IDProjectCategoryView StatusLast Update
0005060SymmetricDSBugpublic2021-07-21 09:12
Reporterrjna Assigned To 
Prioritynone 
Status newResolutionopen 
Product Version3.12.11 
Summary0005060: Difficulty using dbexport to export Oracle DB data
DescriptionHi guys!

I have 2 very simple mock databases in Oracle and I'm trying to export it's contents to mariaDB.

When running the command:

bin/dbexport -p /path_to_my_properties_file > output.sql

I get an empty output.sql file.

When I try:

bin/dbexport -p /path_to_my_properties_file one_of_my_mock_tables > output.sql

I get:

java.lang.RuntimeException: Cannot find table one_of_my_mock_tables in catalog null and schema SYSTEM.

I tried to search the documentation, but it isn't clear what catalog/schema I should use in order to enable dbexport to find the correct table.

Any help would be appreciated!

Thanks,
Ricardo
Tagsdbexport;, dialect: oracle

Activities

rjna

2021-07-21 09:12

reporter   ~0001965

Hi guys!

I consider this solved. I accessed the DB using DBeaver and as able to find the correct schema and then used it in the command successfully.

Thank you!

Issue History

Date Modified Username Field Change
2021-07-19 16:54 rjna New Issue
2021-07-19 16:54 rjna Tag Attached: dbexport;
2021-07-19 16:54 rjna Tag Attached: dialect: oracle
2021-07-21 09:12 rjna Note Added: 0001965