View Issue Details

IDProjectCategoryView StatusLast Update
0005071SymmetricDS ProBugpublic2021-08-13 14:43
Reporterelong Assigned Toelong  
Prioritynormal 
Status resolvedResolutionfixed 
Product Version3.12.0 
Target Version3.12.12Fixed in Version3.12.12 
Summary0005071: Oracle log miner handle multiplexed redo log file
DescriptionOracle log miner should handle multiplexed redo log files, when the same redo log is written to multiple files for redundancy. If a redo log from the same group is added for mining, Oracle will return the following error:

Caused by: java.sql.SQLException: ORA-1289: cannot add duplicate logfile /nredo/FAAAL/redo03n.log

If you query v$logfile, you will see multiple log files for the same group#.

Group# | Status | Type | Member | Is_ | CON_ID
3 Online /redo/FAAAL/redo03.log NO 0
3 Online /nredo/FAAAL/redo03n.log NO 0
2 Online /redo/FAAAL/redo02.log NO 0
2 Online /nredo/FAAAL/redo02n.log NO 0
1 Online /redo/FAAAL/redo01.log NO 0
1 Online /nredo/FAAAL/redo01n.log NO 0
Tagsdialect: oracle, log-miner

Activities

There are no notes attached to this issue.

Issue History

Date Modified Username Field Change
2021-08-13 14:42 elong New Issue
2021-08-13 14:42 elong Status new => assigned
2021-08-13 14:42 elong Assigned To => elong
2021-08-13 14:42 elong Tag Attached: dialect: oracle
2021-08-13 14:42 elong Tag Attached: log-miner
2021-08-13 14:43 elong Status assigned => resolved
2021-08-13 14:43 elong Resolution open => fixed
2021-08-13 14:43 elong Fixed in Version => 3.12.12
2021-08-13 14:43 elong Summary Oracle log miner handle mulitplexed redo log file => Oracle log miner handle multiplexed redo log file