View Issue Details

IDProjectCategoryView StatusLast Update
0005322SymmetricDSBugpublic2022-06-01 16:00
Reporterelong Assigned Toelong  
Prioritynormal 
Status resolvedResolutionfixed 
Product Version3.12.0 
Target Version3.12.17Fixed in Version3.12.17 
Summary0005322: Conflict resolution batch with token parsing error when newlines in data
DescriptionConflict resolution creates a batch to check data integrity, but the batch can get a token parsing error if the primary key data contains newlines or carriage return characters.

2022-06-01 08:54:09,414 ERROR [master-2] [ManageIncomingBatchListener] [master-2-dataloader-34] Failed to load batch 3-67 java.lang.RuntimeException: Sourced file: inline evaluation of: ``if (context != void && context != null) { engine.getDataService().sendNewerDataT . . . '' Token Parsing Error: Lexical error at line 1, column 154. Encountered: "\n" (10), after : "\"\\\"1\\\",\\\"hello": <at unknown location>

    at org.jumpmind.symmetric.io.data.writer.AbstractDatabaseWriter.script(AbstractDatabaseWriter.java:440)
    at org.jumpmind.symmetric.io.data.writer.AbstractDatabaseWriter.write(AbstractDatabaseWriter.java:174)
    at org.jumpmind.symmetric.io.data.writer.NestedDataWriter.write(NestedDataWriter.java:62)
    at org.jumpmind.symmetric.model.ProcessInfoDataWriter.write(ProcessInfoDataWriter.java:84)
    at org.jumpmind.symmetric.io.data.writer.NestedDataWriter.write(NestedDataWriter.java:62)
    at org.jumpmind.symmetric.io.data.writer.TransformWriter.write(TransformWriter.java:190)
    at org.jumpmind.symmetric.io.data.DataProcessor.forEachDataInTable(DataProcessor.java:194)
    at org.jumpmind.symmetric.io.data.DataProcessor.forEachTableInBatch(DataProcessor.java:160)
    at org.jumpmind.symmetric.io.data.DataProcessor.process(DataProcessor.java:108)
    at org.jumpmind.symmetric.service.impl.DataLoaderService$LoadIntoDatabaseOnArrivalListener$2.call(DataLoaderService.java:1023)
    at org.jumpmind.symmetric.service.impl.DataLoaderService$LoadIntoDatabaseOnArrivalListener$2.call(DataLoaderService.java:1)
    at java.util.concurrent.FutureTask.run(FutureTask.java:266)
    at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149)
    at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624)
    at java.lang.Thread.run(Thread.java:750)
Caused by: Sourced file: inline evaluation of: ``if (context != void && context != null) { engine.getDataService().sendNewerDataT . . . '' Token Parsing Error: Lexical error at line 1, column 154. Encountered: "\n" (10), after : "\"\\\"1\\\",\\\"hello": <at unknown location>

    at bsh.Interpreter.eval(Interpreter.java:710)
    at bsh.Interpreter.eval(Interpreter.java:750)
    at bsh.Interpreter.eval(Interpreter.java:739)
    at org.jumpmind.symmetric.io.data.writer.AbstractDatabaseWriter.script(AbstractDatabaseWriter.java:437)
    ... 14 more
Caused by: bsh.TokenMgrError: Lexical error at line 1, column 154. Encountered: "\n" (10), after : "\"\\\"1\\\",\\\"hello"
    at bsh.ParserTokenManager.getNextToken(ParserTokenManager.java:2130)
Steps To Reproducecreate table mytest (id integer, name varchar(255), primary key (id, name));
insert into mytest values (1, 'hello');
-- node 1
update mytest set name = 'hello
test1'
where id = 1;
-- node 2
update mytest set name = 'hello
test2'
where id = 1;
Tagsconflict manager

Relationships

related to 0005318 closedelong Conflict resolution batch with token parsing error when newlines in data 

Activities

There are no notes attached to this issue.

Related Changesets

SymmetricDS: 3.12 eefb81e6

2022-06-01 15:13:20

admin

Details Diff
0005322: Conflict resolution batch with token parsing error when
newlines in data
Affected Issues
0005322
mod - symmetric-core/src/main/java/org/jumpmind/symmetric/load/DefaultDataLoaderFactory.java Diff File
mod - symmetric-core/src/main/java/org/jumpmind/symmetric/service/impl/DataService.java Diff File

Issue History

Date Modified Username Field Change
2022-06-01 15:12 elong New Issue
2022-06-01 15:12 elong Status new => assigned
2022-06-01 15:12 elong Assigned To => elong
2022-06-01 15:12 elong Tag Attached: conflict manager
2022-06-01 15:12 elong Issue generated from: 0005318
2022-06-01 15:12 elong Relationship added related to 0005318
2022-06-01 15:14 elong Status assigned => resolved
2022-06-01 15:14 elong Resolution open => fixed
2022-06-01 15:14 elong Fixed in Version => 3.12.17
2022-06-01 16:00 admin Changeset attached => SymmetricDS 3.12 eefb81e6