View Issue Details

IDProjectCategoryView StatusLast Update
0001599SymmetricDS ProBugpublic2014-06-16 20:26
ReporterelongAssigned Toelong 
PrioritylowSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version3.5.17 
Target Version3.6.0Fixed in Version3.6.0 
Summary0001599: IZPack automated installer error
DescriptionAutomated installer outputs error to standard error, which could be interpreted as an error by some calling scripts. The SymmetricInstallerListener is closing the uninstall JAR output stream eary to fix a corruption bug with the uninstall JAR, but that apparently causes this error in other cases.

java.io.IOException: Stream closed
    at java.util.zip.ZipOutputStream.ensureOpen(ZipOutputStream.java:82)
    at java.util.zip.ZipOutputStream.putNextEntry(ZipOutputStream.java:175)
    at com.izforge.izpack.installer.AutomatedInstaller.writeUninstallData(Unknown Source)
    at com.izforge.izpack.installer.AutomatedInstaller.doInstall(Unknown Source)
    at com.izforge.izpack.installer.Installer.main(Unknown Source)
Steps To Reproduce[ Starting automated installation ]
Read pack list from xml definition.
Try to add to selection [Name: Main Installation and Index: 0]
Try to add to selection [Name: Server Libraries and Index: 1]
Try to add to selection [Name: Required Libraries and Index: 2]
Try to add to selection [Name: Documentation and Index: 3]
Modify pack selection.
[ Starting to unpack ]
[ Processing package: Main Installation (1/4) ]
[ Processing package: Server Libraries (2/4) ]
[ Processing package: Required Libraries (3/4) ]
[ Processing package: Documentation (4/4) ]
[ Unpacking finished ]
[ Creating shortcuts done. ]
[ Add shortcuts to uninstaller done. ]
[ Writing the uninstaller data ... ]
java.io.IOException: Stream closed
    at java.util.zip.ZipOutputStream.ensureOpen(ZipOutputStream.java:82)
    at java.util.zip.ZipOutputStream.putNextEntry(ZipOutputStream.java:175)
    at com.izforge.izpack.installer.AutomatedInstaller.writeUninstallData(Unknown Source)
    at com.izforge.izpack.installer.AutomatedInstaller.doInstall(Unknown Source)
    at com.izforge.izpack.installer.Installer.main(Unknown Source)
[ Automated installation done ]
TagsNo tags attached.

Relationships

related to 0001628 closedelong Installer should escalate privilege on Windows 8 

Activities

elong

2014-03-07 20:39

developer   ~0000498

Related to issue 0001628 because both issues needed IZPack upgraded to latest 5.0 version

Issue History

Date Modified Username Field Change
2014-02-24 09:00 elong New Issue
2014-02-24 09:00 elong Status new => assigned
2014-02-24 09:00 elong Assigned To => elong
2014-03-03 10:13 chenson Priority normal => low
2014-03-07 20:38 elong Relationship added related to 0001628
2014-03-07 20:39 elong Note Added: 0000498
2014-03-07 20:39 elong Status assigned => resolved
2014-03-07 20:39 elong Fixed in Version => 3.6.0
2014-03-07 20:39 elong Resolution open => fixed
2014-06-16 20:26 chenson Status resolved => closed