View Issue Details

IDProjectCategoryView StatusLast Update
0000016SymmetricDSBugpublic2014-02-04 10:10
ReporterAssigned Toelong 
PriorityhighSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version1.5.1 
Target VersionFixed in Version3.3.0 
Summary0000016: GIve options on how to handle non-existant table at client node
DescriptionDefault behavior when an incoming batch does not find a table is to ignore it. It should really be an error. Set a runtime property if you want to ignore missing tables. The reason we originally did this was to enable us to sync to stores that did not have the table deployed yet. maybe we need to add schema version on sym_trigger to enable us to not sync to the databases with a lesser version the version on the sym_trigger table ... We might provide several different 'strategies' for handling the non existent table. Another option might be to automatically create the table.
TagsNo tags attached.

Activities

elong

2014-02-04 10:10

developer   ~0000441

Use parameter dataloader.ignore.missing.tables=false

Issue History

Date Modified Username Field Change
2012-06-18 14:12 admin Target Version 3.1.0 =>
2014-02-04 10:10 elong Note Added: 0000441
2014-02-04 10:10 elong Status new => closed
2014-02-04 10:10 elong Assigned To => elong
2014-02-04 10:10 elong Resolution open => fixed
2014-02-04 10:10 elong Fixed in Version 3.1.0 => 3.3.0