View Issue Details

IDProjectCategoryView StatusLast Update
0002820SymmetricDSBugpublic2016-09-29 21:01
ReporterwrygielAssigned Tommichalek 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version3.8.3 
Target Version3.8.5Fixed in Version3.8.5 
Summary0002820: Unclear meaning of dbcompare's --use-sym-config
DescriptionFrom dbcompare --help:

    --use-sym-config true|false. If true, sym_trigger,
                            sym_transform, etc. will be consulted to build
                            up the datamodel to compare.

However, none of the following invokations work:

dbcompare <args> --use-sym-config
-> RuntimeException: includedTableNames not provided, includedTableNames must be provided when not comparing using SymmetricDS config.

dbcompare <args> --use-sym-config true
-> DbCompare - No source table found for table name true

dbcompare <args> --use-sym-config=true
-> DbCompare - No source table found for table name true
TagsNo tags attached.

Activities

mmichalek

2016-09-22 12:06

administrator   ~0000860

Hello,

Thanks for the feedback. --use-sym-config actually defaults to true, so I am not sure why you ran into that in the first place. The most basic usage of dbcompare would be like this, with both the source and target provided. This suggests to SymmetricDS to compare all tables that sync from corp-000 to store-001.

-s target/engines/corp-000.properties -t target/engines/store-001.properties

Can you let me know an example of the full set of args you are providing?

wrygiel

2016-09-22 16:59

reporter   ~0000861

> --use-sym-config actually defaults to true

Oh, I was sure it's the opposite, thanks!

> so I am not sure why you ran into that in the first place.

I have just assumed that --use-sym-config is false by default. It is named "--use-sym-config", but - as I understand it - it actually does exactly the opposite: when I provide it, the scripts stops to use sym-config?

I also got some error the first time I run dbcompare without it, but I don't remember exactly... I have upgraded to 3.8.4 since reporting this issue and now it works correctly (when I skip the "--use-sym-config" parameter). Thank you!

mmichalek

2016-09-22 17:12

administrator   ~0000862

Ah, you are correct. This is a bug. The command line is ignoring the true or false value on the --use-sym-config, which causes it to always change to false when --use-sym-config is specified. In 3.8.5, if --use-sym-config is NOT specified, it will default to true, otherwise it should respect a true or false value.

Thanks for the feedback and I am glad it's working for you now.

Related Changesets

SymmetricDS: 3.8 04f89349

2016-09-22 17:16:01

mmichalek

Details Diff
0002820: Unclear meaning of dbcompare's --use-sym-config
0002820
mod - symmetric-client/src/main/java/org/jumpmind/symmetric/DbCompareCommand.java Diff File
mod - symmetric-client/src/main/resources/symmetric-messages.properties Diff File

Issue History

Date Modified Username Field Change
2016-09-22 05:30 wrygiel New Issue
2016-09-22 12:06 mmichalek Note Added: 0000860
2016-09-22 16:59 wrygiel Note Added: 0000861
2016-09-22 17:12 mmichalek Note Added: 0000862
2016-09-22 17:16 mmichalek Assigned To => mmichalek
2016-09-22 17:16 mmichalek Status new => resolved
2016-09-22 17:16 mmichalek Resolution open => fixed
2016-09-22 17:16 mmichalek Fixed in Version => 3.8.5
2016-09-22 17:16 mmichalek Target Version => 3.8.5
2016-09-22 18:00 mmichalek Changeset attached => SymmetricDS 3.8 04f89349
2016-09-29 21:01 admin Status resolved => closed