View Issue Details

IDProjectCategoryView StatusLast Update
0003613SymmetricDS ProImprovementpublic2018-06-29 08:39
ReporterpmattensAssigned Toelong 
PrioritynormalSeverityfeatureReproducibilityN/A
Status resolvedResolutionfixed 
Product Version3.7.36 
Target Version3.9.10Fixed in Version3.9.10 
Summary0003613: Web Console logging - user create, delete, logout, and change password events
DescriptionWe have found no logging capability for the Symmetric Web Console. Is there a way to log actions that happen with the console: ie logins, logouts, user creation ...
TagsNo tags attached.

Activities

elong

2018-06-28 12:39

developer   ~0001212

In SymmetricDS Pro 3.9, there is a sym_console_event table that logs events like that. Currently it is logging user logins. I will add user create, delete, and logout for this issue. Not sure if I can make logout accurate, because the user may let their session timeout. I'll see how difficult it would be to capture the timeout and record the logout.

pmattens

2018-06-28 13:39

reporter   ~0001213

I assume there is not capability for this in 3.7?

elong

2018-06-28 13:51

developer   ~0001214

Not in 3.7, because it is a new feature in 3.9.

pmattens

2018-06-28 14:05

reporter   ~0001215

Thanks.

Issue History

Date Modified Username Field Change
2018-06-28 10:33 pmattens New Issue
2018-06-28 12:39 elong Note Added: 0001212
2018-06-28 13:39 pmattens Note Added: 0001213
2018-06-28 13:51 elong Note Added: 0001214
2018-06-28 14:05 pmattens Note Added: 0001215
2018-06-29 08:39 elong Assigned To => elong
2018-06-29 08:39 elong Status new => resolved
2018-06-29 08:39 elong Resolution open => fixed
2018-06-29 08:39 elong Fixed in Version => 3.9.10
2018-06-29 08:39 elong Target Version => 3.9.10
2018-06-29 08:39 elong Summary Symmetric DS WebConsole logging => Web Console logging - user create, delete, logout, and change password events