View Issue Details

IDProjectCategoryView StatusLast Update
0003926SymmetricDSBugpublic2019-08-26 08:55
ReportermmichalekAssigned Toadmin 
Prioritynormal 
Status closedResolutionunable to reproduce 
Product Version3.10.0 
Target VersionFixed in Version 
Summary0003926: Symmetric Jobs don't start when an error during config sync happens
DescriptionBelow is an example case. The client requested a config refresh, and an IO exception occurred during the config refresh. After that, the jobs did not start (even after the user stopped and started the node, with the process still running.) Things did clear up after restarting the Symmetric process. To reproduce, one might try forcing an exception similar to that stack trace.

2019-04-25 14:32:39,673 INFO [node-group-node-lab] [DataLoaderService] [symmetric-engine-startup-2] Requesting current configuration {symmetricVersion=3.9.16, configVersion=null}
...
2019-04-25 14:33:27,465 WARN [node-group-node-lab] [ManageIncomingBatchListener] [node-group-node-lab-dataloader-1] Failed to load batch node--9999 StackTraceKey.init [IoException:1293242606]
org.jumpmind.exception.IoException: java.io.IOException: Stale file handle
    at org.jumpmind.symmetric.io.data.reader.ProtocolDataReader.readNext(ProtocolDataReader.java:308)
    at org.jumpmind.symmetric.io.data.reader.ProtocolDataReader.nextData(ProtocolDataReader.java:360)
    at org.jumpmind.symmetric.io.data.DataProcessor.forEachDataInTable(DataProcessor.java:198)
    at org.jumpmind.symmetric.io.data.DataProcessor.forEachTableInBatch(DataProcessor.java:177)
    at org.jumpmind.symmetric.io.data.DataProcessor.process(DataProcessor.java:123)
    at org.jumpmind.symmetric.service.impl.DataLoaderService$LoadIntoDatabaseOnArrivalListener$2.call(DataLoaderService.java:1039)
    at org.jumpmind.symmetric.service.impl.DataLoaderService$LoadIntoDatabaseOnArrivalListener$2.call(DataLoaderService.java:1016)
    at java.util.concurrent.FutureTask.run(FutureTask.java:266)
    at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149)
    at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624)
    at java.lang.Thread.run(Thread.java:748)
Caused by: java.io.IOException: Stale file handle
    at java.io.FileInputStream.readBytes(Native Method)
    at java.io.FileInputStream.read(FileInputStream.java:255)
    at java.util.zip.InflaterInputStream.fill(InflaterInputStream.java:238)
    at java.util.zip.InflaterInputStream.read(InflaterInputStream.java:158)
    at java.util.zip.GZIPInputStream.read(GZIPInputStream.java:117)
    at sun.nio.cs.StreamDecoder.readBytes(StreamDecoder.java:284)
    at sun.nio.cs.StreamDecoder.implRead(StreamDecoder.java:326)
    at sun.nio.cs.StreamDecoder.read(StreamDecoder.java:178)
    at java.io.InputStreamReader.read(InputStreamReader.java:184)
    at java.io.BufferedReader.fill(BufferedReader.java:161)
    at java.io.BufferedReader.read1(BufferedReader.java:212)
    at java.io.BufferedReader.read(BufferedReader.java:286)
    at org.jumpmind.symmetric.csv.CsvReader.checkDataLength(CsvReader.java:1160)
    at org.jumpmind.symmetric.csv.CsvReader.readRecord(CsvReader.java:637)
    at org.jumpmind.symmetric.io.data.reader.ProtocolDataReader.readNext(ProtocolDataReader.java:145)
    ... 10 more
2019-04-25 14:33:27,546 ERROR [node-group-node-lab] [DataLoaderService] [symmetric-engine-startup-2] Failed to process batch StackTraceKey [IoException:1293242606]
...
2019-04-25 14:33:36,879 INFO [node-group-node-lab] [PullJob] [node-group-node-lab-job-1] The engine is not currently started, will not run job 'Pull'
Tagssym/sym_service

Activities

elong

2019-05-30 15:39

developer   ~0001514

I tried throwing an exception in ProtocolDataReader during the PullService.pullConfigData() at startup, but it catches all exceptions. My engine started up fine. Any ideas on how to reproduce?

Issue History

Date Modified Username Field Change
2019-04-26 13:48 mmichalek New Issue
2019-05-09 11:04 elong Tag Attached: sym/sym_service
2019-05-30 15:39 elong Status new => feedback
2019-05-30 15:39 elong Note Added: 0001514
2019-08-26 08:55 admin Assigned To => admin
2019-08-26 08:55 admin Status feedback => closed
2019-08-26 08:55 admin Resolution open => unable to reproduce