View Issue Details

IDProjectCategoryView StatusLast Update
0003979SymmetricDSBugpublic2019-08-26 08:49
ReporterialnahrawyAssigned Toadmin 
Priorityhigh 
Status closedResolutionunable to reproduce 
Product Version3.7.16 
Target VersionFixed in Version 
Summary0003979: symmetric-wrapper is crashed after few days
DescriptionDear Team,

Symmetric-wrapper is crashed after few days due to resource constraint (Error log: not enough space to reguard - increase StackShadowPages) .

In windows service it showing that the symmetricds service is stopped . When trying to start the service (wrapper), it stops again. as the main java service (symmetricds ) is already running , and I have to kill java process to start it again.

2019-04-29 12:06:37,274 WARN [startup] [AbstractLifeCycle] [main] FAILED SelectChannelConnector@0.0.0.0:8741: java.net.BindException: Address already in use: bind
java.net.BindException: Address already in use: bind
                at sun.nio.ch.Net.bind0(Native Method)
                at sun.nio.ch.Net.bind(Unknown Source)
                at sun.nio.ch.Net.bind(Unknown Source)
                at sun.nio.ch.ServerSocketChannelImpl.bind(Unknown Source)
                at sun.nio.ch.ServerSocketAdaptor.bind(Unknown Source)



Thanks,
Islam Al-Nahrawy
Tagssym/sym_service

Relationships

related to 0003430 closedelong Service wrapper should verify and kill abandoned processes 

Activities

elong

2019-05-29 07:50

developer   ~0001508

What version of Java?

elong

2019-05-29 07:55

developer   ~0001509

Can you post your wrapper.log and the Java crash file (usually named hs_err_pid<pid>.log)?

ialnahrawy

2019-05-30 05:51

reporter   ~0001511

JRE version: Java(TM) SE Runtime Environment (8.0_152-b16) (build 1.8.0_152-b16)

wrapper.log (44,585 bytes)
sym_service.conf (3,091 bytes)
hs_err_pid21248.log (952 bytes)

elong

2019-05-30 07:50

developer   ~0001512

I've never seen a crash file like that, without any threads, frames, or heap. Is this Windows 64-bit? If so, I'm wondering if it would help to switch to 64-bit Java. It looks like you're running 32-bit Java.

If that doesn't help or not an option, then we could try adding some lines to the sym_service.conf file. This line would switch to server VM, which adjusts some of the runtime sizes:

wrapper.java.additional.12=-server

Since it complains about StackShadowPages, you could try adjusting those to add more. Here are some lines to add:

wrapper.java.additional.13=-XX:StackShadowPages=7
wrapper.java.additional.14=-Xss90k

Issue History

Date Modified Username Field Change
2019-05-29 07:24 ialnahrawy New Issue
2019-05-29 07:48 elong Relationship added related to 0003430
2019-05-29 07:50 elong Note Added: 0001508
2019-05-29 07:55 elong Status new => feedback
2019-05-29 07:55 elong Note Added: 0001509
2019-05-30 05:51 ialnahrawy File Added: wrapper.log
2019-05-30 05:51 ialnahrawy File Added: sym_service.conf
2019-05-30 05:51 ialnahrawy File Added: hs_err_pid21248.log
2019-05-30 05:51 ialnahrawy Note Added: 0001511
2019-05-30 05:51 ialnahrawy Status feedback => new
2019-05-30 07:50 elong Note Added: 0001512
2019-05-31 10:19 elong Status new => feedback
2019-05-31 10:19 elong Tag Attached: sym/sym_service
2019-08-26 08:49 admin Assigned To => admin
2019-08-26 08:49 admin Status feedback => closed
2019-08-26 08:49 admin Resolution open => unable to reproduce