View Issue Details

IDProjectCategoryView StatusLast Update
0004164SymmetricDS ProBugpublic2019-12-02 15:10
Reporterzeljko.katic@procosafe.noAssigned Toelong 
Prioritynormal 
Status closedResolutionfixed 
Product Version3.11.0 
Target Version3.11.1Fixed in Version3.11.1 
Summary0004164: BatchUpdateException: Duplicate entry '24-378' for key 'PRIMARY'
DescriptionWhen joining a client(with MSSQL) to SymmetricDS server(withMysql) Duplicate entry appears. It happens even when the client db is truncated.
Tried to fix the problem with the regular MySQL fixes on the Duplicate Entry matter but failing. Also after clearing the log the error just reappears and cannot find the duplicated entry in the server db. This problem was not appearing in version 3.10.4
Steps To ReproduceAdd a local node to the server.
TagsNo tags attached.

Relationships

duplicate of 0004162 closedelong SymmetricDS Routing unique key violation sym_data_event 

Activities

zeljko.katic@procosafe.no

2019-11-24 16:47

reporter  

logs.zip (189,933 bytes)

elong

2019-11-24 16:56

developer   ~0001654

This looks like the same as issue 0004162 . We'll try to do a release soon this week as it's easy to get with more than 2 node groups.

zeljko.katic@procosafe.no

2019-11-24 17:13

reporter   ~0001655

Yes it does. Because I have not noticed this in 3.10.4. Thank you

Issue History

Date Modified Username Field Change
2019-11-24 16:47 zeljko.katic@procosafe.no New Issue
2019-11-24 16:47 zeljko.katic@procosafe.no File Added: logs.zip
2019-11-24 16:54 elong Relationship added duplicate of 0004162
2019-11-24 16:56 elong Note Added: 0001654
2019-11-24 17:13 zeljko.katic@procosafe.no Note Added: 0001655
2019-11-25 09:07 elong Assigned To => elong
2019-11-25 09:07 elong Status new => resolved
2019-11-25 09:07 elong Resolution open => fixed
2019-11-25 09:07 elong Fixed in Version => 3.11.1
2019-11-25 09:07 elong Target Version => 3.11.1
2019-11-25 09:07 elong Description Updated View Revisions
2019-12-02 15:10 admin Status resolved => closed