View Issue Details

IDProjectCategoryView StatusLast Update
0001419SymmetricDSBugpublic2014-02-02 20:53
ReporterjarmosAssigned Tochenson 
Priorityurgent 
Status closedResolutionfixed 
Product Version3.5.6 
Target Version3.5.7Fixed in Version3.5.7 
Summary0001419: USE_STREAM_LOBS=1 in Oracle does not replicate LOB data
DescriptionWe just upgraded Symmetricds from 3.4.x to latest 3.5.6 and now none of the BLOB data is replicated between the systems. The sym_triggers are configured to have USE_STREAM_LOBS=1 and USE_CAPTURE_LOBS=0. All the LOB data is now replicated as NULL to another system.

LOB replication did work fine with 3.4.x SymmetricDS

I have tried to change the configuration to USE_STREAM_LOBS=1 and USE_CAPTURE_LOBS=1, but it did not help.

I also tried to change configuration to USE_STREAM_LOBS=0 and USE_CAPTURE_LOBS=1, but this causes the SymmetricDS basically freeze. It will take so much time to process the rows that the replication cannot keep up with the incoming rows. The CPU for SymmetricDS is in top all the time with this setting.

We are having three node system with two masters (read&write) and one read-only database.
Master 1 is running on Windows Server 2008 R2 + Oracle 11gR2 11.2.0.2
Master 2 is running on Oracle Linux 6.4 + Oracle 11gR2 11.2.0.3
Backup db is running on Oracle Linux 6.4 + Oracle 11gR2 11.2.0.3

This is our production system and the data is currently corropting quickly. I had to take master 2 offline and to stop replication to prevent data corruption.

Oracle databases are performing OK all the time, only problem right now is the replication.

Could you please help urgently with this.
Steps To Reproducecreate a table which have big LOB values in Oracle, set the sym_trigger for it to USE_STREAM_LOBS=1 and USE_CAPTURE_LOBS=0
=> the LOB data is replivated as NULL to another system
TagsNo tags attached.

Activities

jarmos

2013-09-13 03:02

reporter   ~0000377

This problem seems to happen with NCLOB and CLOB fields too in addition to BLOB. This problem basically makes SymmetricDS to be sompletely useless.

Related Changesets

SymmetricDS: master 5f5b6c10

2013-09-13 08:42:49

chenson

Details Diff
0001419: USE_STREAM_LOBS=1 in Oracle does not replicate LOB data
0001419
mod - symmetric-core/src/main/java/org/jumpmind/symmetric/service/impl/DataExtractorService.java Diff File
mod - symmetric-core/src/test/java/org/jumpmind/symmetric/test/TestTablesService.java Diff File
mod - symmetric-server/src/test/java/org/jumpmind/symmetric/test/SimpleIntegrationTest.java Diff File

Issue History

Date Modified Username Field Change
2013-09-12 08:13 jarmos New Issue
2013-09-13 03:02 jarmos Note Added: 0000377
2013-09-13 07:52 chenson Assigned To => chenson
2013-09-13 07:52 chenson Status new => assigned
2013-09-13 07:52 chenson Target Version => 3.5.7
2013-09-13 08:44 chenson Status assigned => resolved
2013-09-13 08:44 chenson Fixed in Version => 3.5.7
2013-09-13 08:44 chenson Resolution open => fixed
2013-09-14 17:24 chenson Status resolved => closed
2014-02-02 20:53 Changeset attached => SymmetricDS trunk r7693
2015-07-30 21:49 chenson Changeset attached => SymmetricDS master 5f5b6c10