View Issue Details

IDProjectCategoryView StatusLast Update
0001965SymmetricDSBugpublic2014-09-17 18:01
ReporterhrkAssigned Tochenson 
Prioritynormal 
Status closedResolutionreopened 
Product Version3.6.7 
Target Version3.6.8Fixed in Version3.6.8 
Summary0001965: Initial load uses wrong case on Oracle to PostgreSQL table creation.
DescriptionAn Oracle -> PostgreSQL replication fails during initial load because the table name in a FK is created lower-case as table identifier, then upper-case as FK reference.
Additional Information[auth-slave-001] - DefaultDatabaseWriter - About to create table using the following definition: <?xml version="1.0"?>
<!DOCTYPE database SYSTEM "http://db.apache.org/torque/dtd/database">
<database name="dataextractor">
        <table name="DECODIFICA_NAVE">
                <column name="CODICE" primaryKey="true" required="true" type="INTEGER" size="22">
                        <platform-column name="oracle" type="NUMBER" size="22"/>
                </column>
                <column name="DESCRIZIONE" type="VARCHAR" size="255">
                        <platform-column name="oracle" type="VARCHAR2" size="255"/>
                </column>
                <column name="COLORE" type="VARCHAR" size="7">
                        <platform-column name="oracle" type="VARCHAR2" size="7"/>
                </column>
        </table>
</database>
[auth-slave-001] - PostgreSqlDatabasePlatform - Running alter sql:
CREATE TABLE "decodifica_nave"(
    "codice" INTEGER NOT NULL,
    "descrizione" VARCHAR(255),
    "colore" VARCHAR(7),
    PRIMARY KEY ("codice")
);

[auth-slave-001] - PullService - Pull data received from auth-master:auth-master-000:auth-master-000. 3 rows and 3 batches were processed
[auth-slave-001] - PullService - Immediate pull requested while in reload mode
[auth-slave-001] - DefaultDatabaseWriter - About to create table using the following definition: <?xml version="1.0"?>
<!DOCTYPE database SYSTEM "http://db.apache.org/torque/dtd/database">
<database name="dataextractor">
        <table name="NAVE">
                <column name="OID" primaryKey="true" required="true" type="INTEGER" size="22">
                        <platform-column name="oracle" type="NUMBER" size="22"/>
                </column>
                <column name="NOME" type="VARCHAR" size="255">
                        <platform-column name="oracle" type="VARCHAR2" size="255"/>
                </column>
                <column name="MMSI" type="VARCHAR" size="9">
                        <platform-column name="oracle" type="VARCHAR2" size="9"/>
                </column>
                <column name="IMO" type="VARCHAR" size="7">
                        <platform-column name="oracle" type="VARCHAR2" size="7"/>
                </column>
                <column name="TIPONAVE" type="INTEGER" size="22">
                        <platform-column name="oracle" type="NUMBER" size="22"/>
                </column>
                <column name="CAPACITA" type="DOUBLE" size="126">
                        <platform-column name="oracle" type="FLOAT" size="126"/>
                </column>
                <foreign-key name="SYS_C00150324" foreignTable="DECODIFICA_NAVE">
                        <reference local="TIPONAVE" foreign="CODICE"/>
                </foreign-key>
        </table>
</database>
[auth-slave-001] - PostgreSqlDatabasePlatform - Running alter sql:
CREATE TABLE "nave"(
    "oid" INTEGER NOT NULL,
    "nome" VARCHAR(255),
    "mmsi" VARCHAR(9),
    "imo" VARCHAR(7),
    "tiponave" INTEGER,
    "capacita" DOUBLE PRECISION,
    PRIMARY KEY ("oid")
);
ALTER TABLE "nave"
    ADD CONSTRAINT "SYS_C00150324" FOREIGN KEY ("TIPONAVE") REFERENCES "DECODIFICA_NAVE" ("CODICE");

[auth-slave-001] - JdbcSqlTemplate - ERROR: relation "DECODIFICA_NAVE" does not exist. Failed to execute: ALTER TABLE "nave"
ADD CONSTRAINT "SYS_C00150324" FOREIGN KEY ("TIPONAVE") REFERENCES "DECODIFICA_NAVE" ("CODICE")
[auth-slave-001] - DefaultDatabaseWriter - Failed to alter table using the following xml: <?xml version="1.0"?>
<!DOCTYPE database SYSTEM "http://db.apache.org/torque/dtd/database">
<database name="dataextractor">
        <table name="NAVE">
                <column name="OID" primaryKey="true" required="true" type="INTEGER" size="22">
                        <platform-column name="oracle" type="NUMBER" size="22"/>
                </column>
                <column name="NOME" type="VARCHAR" size="255">
                        <platform-column name="oracle" type="VARCHAR2" size="255"/>
                </column>
                <column name="MMSI" type="VARCHAR" size="9">
                        <platform-column name="oracle" type="VARCHAR2" size="9"/>
                </column>
                <column name="IMO" type="VARCHAR" size="7">
                        <platform-column name="oracle" type="VARCHAR2" size="7"/>
                </column>
                <column name="TIPONAVE" type="INTEGER" size="22">
                        <platform-column name="oracle" type="NUMBER" size="22"/>
                </column>
                <column name="CAPACITA" type="DOUBLE" size="126">
                        <platform-column name="oracle" type="FLOAT" size="126"/>
                </column>
                <foreign-key name="SYS_C00150324" foreignTable="DECODIFICA_NAVE">
                        <reference local="TIPONAVE" foreign="CODICE"/>
                </foreign-key>
        </table>
</database>
[auth-slave-001] - DataLoaderService - Failed to load batch auth-master-000-9 because: ERROR: relation "DECODIFICA_NAVE" does not exist
org.jumpmind.db.sql.SqlException: ERROR: relation "DECODIFICA_NAVE" does not exist
        at org.jumpmind.db.sql.AbstractSqlTemplate.translate(AbstractSqlTemplate.java:288)
        at org.jumpmind.db.sql.AbstractSqlTemplate.translate(AbstractSqlTemplate.java:279)
        at org.jumpmind.db.sql.JdbcSqlTemplate.execute(JdbcSqlTemplate.java:425)
        at org.jumpmind.db.sql.JdbcSqlTemplate.update(JdbcSqlTemplate.java:338)
        at org.jumpmind.db.sql.SqlScript.execute(SqlScript.java:107)
        at org.jumpmind.db.platform.AbstractDatabasePlatform.alterTables(AbstractDatabasePlatform.java:200)
        at org.jumpmind.db.platform.AbstractDatabasePlatform.alterDatabase(AbstractDatabasePlatform.java:173)
        at org.jumpmind.symmetric.io.data.writer.DefaultDatabaseWriter.create(DefaultDatabaseWriter.java:498)
        at org.jumpmind.symmetric.io.data.writer.AbstractDatabaseWriter.write(AbstractDatabaseWriter.java:166)
        at org.jumpmind.symmetric.io.data.writer.AbstractDatabaseWriter.write(AbstractDatabaseWriter.java:131)
        at org.jumpmind.symmetric.io.data.writer.NestedDataWriter.write(NestedDataWriter.java:64)
        at org.jumpmind.symmetric.model.ProcessInfoDataWriter.write(ProcessInfoDataWriter.java:65)
        at org.jumpmind.symmetric.io.data.writer.NestedDataWriter.write(NestedDataWriter.java:64)
        at org.jumpmind.symmetric.io.data.writer.TransformWriter.write(TransformWriter.java:236)
        at org.jumpmind.symmetric.io.data.DataProcessor.forEachDataInTable(DataProcessor.java:199)
        at org.jumpmind.symmetric.io.data.DataProcessor.forEachTableInBatch(DataProcessor.java:169)
        at org.jumpmind.symmetric.io.data.DataProcessor.process(DataProcessor.java:115)
        at org.jumpmind.symmetric.service.impl.DataLoaderService$LoadIntoDatabaseOnArrivalListener.end(DataLoaderService.java:802)
        at org.jumpmind.symmetric.io.data.writer.StagingDataWriter.notifyEndBatch(StagingDataWriter.java:75)
        at org.jumpmind.symmetric.io.data.writer.AbstractProtocolDataWriter.end(AbstractProtocolDataWriter.java:220)
        at org.jumpmind.symmetric.io.data.DataProcessor.process(DataProcessor.java:129)
        at org.jumpmind.symmetric.service.impl.DataLoaderService.loadDataFromTransport(DataLoaderService.java:431)
        at org.jumpmind.symmetric.service.impl.DataLoaderService.loadDataFromPull(DataLoaderService.java:269)
        at org.jumpmind.symmetric.service.impl.PullService.execute(PullService.java:133)
        at org.jumpmind.symmetric.service.impl.NodeCommunicationService$2.run(NodeCommunicationService.java:307)
        at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)
        at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)
        at java.lang.Thread.run(Thread.java:745)
Caused by: org.postgresql.util.PSQLException: ERROR: relation "DECODIFICA_NAVE" does not exist
        at org.postgresql.core.v2.QueryExecutorImpl.receiveErrorMessage(QueryExecutorImpl.java:561)
        at org.postgresql.core.v2.QueryExecutorImpl.processResults(QueryExecutorImpl.java:484)
        at org.postgresql.core.v2.QueryExecutorImpl.execute(QueryExecutorImpl.java:364)
        at org.postgresql.core.v2.QueryExecutorImpl.execute(QueryExecutorImpl.java:258)
        at org.postgresql.jdbc2.AbstractJdbc2Statement.execute(AbstractJdbc2Statement.java:555)
        at org.postgresql.jdbc2.AbstractJdbc2Statement.executeWithFlags(AbstractJdbc2Statement.java:403)
        at org.postgresql.jdbc2.AbstractJdbc2Statement.execute(AbstractJdbc2Statement.java:395)
        at org.apache.commons.dbcp.DelegatingStatement.execute(DelegatingStatement.java:264)
        at org.apache.commons.dbcp.DelegatingStatement.execute(DelegatingStatement.java:264)
        at org.jumpmind.db.sql.JdbcSqlTemplate$6.execute(JdbcSqlTemplate.java:351)
        at org.jumpmind.db.sql.JdbcSqlTemplate$6.execute(JdbcSqlTemplate.java:338)
        at org.jumpmind.db.sql.JdbcSqlTemplate.execute(JdbcSqlTemplate.java:423)
        ... 25 more
TagsNo tags attached.

Activities

chenson

2014-09-15 08:36

administrator   ~0000573

Last edited: 2014-09-15 08:36

View 2 revisions

I think you can work around this by setting dataloader.create.table.alter.to.match.db.case=false

hrk

2014-09-15 08:46

reporter   ~0000574

Thank you, I put it in the slave-configuration (PostgreSQL) and the initial load went further, then died with a similar issue (I think). What is strange is that a similar table was successfully created right before the failing one:

[auth-slave-001] - PullService - Immediate pull requested while in reload mode
[auth-slave-001] - DefaultDatabaseWriter - About to create table using the following definition: <?xml version="1.0"?>
<!DOCTYPE database SYSTEM "http://db.apache.org/torque/dtd/database">
<database name="dataextractor">
        <table name="AUTH_UTENTE_RUOLO">
                <column name="UTENTE" primaryKey="true" required="true" type="VARCHAR" size="10">
                        <platform-column name="oracle" type="VARCHAR2" size="10"/>
                </column>
                <column name="RUOLO" primaryKey="true" required="true" type="VARCHAR" size="31">
                        <platform-column name="oracle" type="VARCHAR2" size="31"/>
                </column>
                <column name="APP" type="VARCHAR" size="31" default="monitoraggioScorte">
                        <platform-column name="oracle" type="VARCHAR2" size="31"/>
                </column>
                <foreign-key name="SYS_C00150327" foreignTable="AUTH_RUOLO">
                        <reference local="RUOLO" foreign="NOME"/>
                </foreign-key>
                <foreign-key name="SYS_C00150328" foreignTable="AUTH_UTENTE">
                        <reference local="UTENTE" foreign="MATRICOLA"/>
                </foreign-key>
        </table>
</database>
[auth-slave-001] - PostgreSqlDatabasePlatform - Running alter sql:
CREATE TABLE "AUTH_UTENTE_RUOLO"(
    "UTENTE" VARCHAR(10) NOT NULL,
    "RUOLO" VARCHAR(31) NOT NULL,
    "APP" VARCHAR(31) DEFAULT 'monitoraggioScorte',
    PRIMARY KEY ("UTENTE", "RUOLO")
);
ALTER TABLE "AUTH_UTENTE_RUOLO"
    ADD CONSTRAINT "SYS_C00150327" FOREIGN KEY ("RUOLO") REFERENCES "AUTH_RUOLO" ("NOME");
ALTER TABLE "AUTH_UTENTE_RUOLO"
    ADD CONSTRAINT "SYS_C00150328" FOREIGN KEY ("UTENTE") REFERENCES "AUTH_UTENTE" ("MATRICOLA");

[auth-slave-001] - PullService - Pull data received from auth-master:auth-master-000:auth-master-000. 32 rows and 32 batches were processed
[auth-slave-001] - PullService - Immediate pull requested while in reload mode
[auth-slave-001] - DataLoaderService - Failed to load batch auth-master-000-37 because: ERROR: relation "auth_utente_ruolo" does not exist at character 13
org.jumpmind.db.sql.SqlException: ERROR: relation "auth_utente_ruolo" does not exist at character 13
        at org.jumpmind.db.sql.AbstractSqlTemplate.translate(AbstractSqlTemplate.java:288)
        at org.jumpmind.db.sql.AbstractSqlTemplate.translate(AbstractSqlTemplate.java:279)
        at org.jumpmind.db.sql.JdbcSqlTransaction.executeCallback(JdbcSqlTransaction.java:338)
        at org.jumpmind.db.sql.JdbcSqlTransaction.prepareAndExecute(JdbcSqlTransaction.java:309)
        at org.jumpmind.symmetric.io.data.writer.DefaultDatabaseWriter.sql(DefaultDatabaseWriter.java:528)
        at org.jumpmind.symmetric.io.data.writer.AbstractDatabaseWriter.write(AbstractDatabaseWriter.java:163)
        at org.jumpmind.symmetric.io.data.writer.AbstractDatabaseWriter.write(AbstractDatabaseWriter.java:131)
        at org.jumpmind.symmetric.io.data.writer.NestedDataWriter.write(NestedDataWriter.java:64)
        at org.jumpmind.symmetric.model.ProcessInfoDataWriter.write(ProcessInfoDataWriter.java:65)
        at org.jumpmind.symmetric.io.data.writer.NestedDataWriter.write(NestedDataWriter.java:64)
        at org.jumpmind.symmetric.io.data.writer.TransformWriter.write(TransformWriter.java:236)
        at org.jumpmind.symmetric.io.data.DataProcessor.forEachDataInTable(DataProcessor.java:199)
        at org.jumpmind.symmetric.io.data.DataProcessor.forEachTableInBatch(DataProcessor.java:169)
        at org.jumpmind.symmetric.io.data.DataProcessor.process(DataProcessor.java:115)
        at org.jumpmind.symmetric.service.impl.DataLoaderService$LoadIntoDatabaseOnArrivalListener.end(DataLoaderService.java:802)
        at org.jumpmind.symmetric.io.data.writer.StagingDataWriter.notifyEndBatch(StagingDataWriter.java:75)
        at org.jumpmind.symmetric.io.data.writer.AbstractProtocolDataWriter.end(AbstractProtocolDataWriter.java:220)
        at org.jumpmind.symmetric.io.data.DataProcessor.process(DataProcessor.java:129)
        at org.jumpmind.symmetric.service.impl.DataLoaderService.loadDataFromTransport(DataLoaderService.java:431)
        at org.jumpmind.symmetric.service.impl.DataLoaderService.loadDataFromPull(DataLoaderService.java:269)
        at org.jumpmind.symmetric.service.impl.PullService.execute(PullService.java:133)
        at org.jumpmind.symmetric.service.impl.NodeCommunicationService$2.run(NodeCommunicationService.java:307)
        at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)
        at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)
        at java.lang.Thread.run(Thread.java:745)
Caused by: org.postgresql.util.PSQLException: ERROR: relation "auth_utente_ruolo" does not exist at character 13
        at org.postgresql.core.v2.QueryExecutorImpl.receiveErrorMessage(QueryExecutorImpl.java:561)
        at org.postgresql.core.v2.QueryExecutorImpl.processResults(QueryExecutorImpl.java:484)
        at org.postgresql.core.v2.QueryExecutorImpl.execute(QueryExecutorImpl.java:364)
        at org.postgresql.core.v2.QueryExecutorImpl.execute(QueryExecutorImpl.java:258)
        at org.postgresql.jdbc2.AbstractJdbc2Statement.execute(AbstractJdbc2Statement.java:555)
        at org.postgresql.jdbc2.AbstractJdbc2Statement.executeWithFlags(AbstractJdbc2Statement.java:417)
        at org.postgresql.jdbc2.AbstractJdbc2Statement.execute(AbstractJdbc2Statement.java:410)
        at org.apache.commons.dbcp.DelegatingPreparedStatement.execute(DelegatingPreparedStatement.java:172)
        at org.apache.commons.dbcp.DelegatingPreparedStatement.execute(DelegatingPreparedStatement.java:172)
        at org.jumpmind.db.sql.JdbcSqlTransaction$5.execute(JdbcSqlTransaction.java:319)
        at org.jumpmind.db.sql.JdbcSqlTransaction$5.execute(JdbcSqlTransaction.java:309)
        at org.jumpmind.db.sql.JdbcSqlTransaction.executeCallback(JdbcSqlTransaction.java:336)
        ... 22 more
[auth-master-000] - AcknowledgeService - The outgoing batch auth-slave-001-37 failed. ERROR: relation "auth_utente_ruolo" does not exist at character 13
[auth-slave-001] - PullService - There was a failure while pulling data from auth-master:auth-master-000:auth-master-000. 33 rows and 33 batches were processed

hrk

2014-09-15 08:47

reporter   ~0000575

This one worked fine (earlier in the queue):
[auth-slave-001] - DefaultDatabaseWriter - About to create table using the following definition: <?xml version="1.0"?>
<!DOCTYPE database SYSTEM "http://db.apache.org/torque/dtd/database">
<database name="dataextractor">
        <table name="AUTH_RUOLO_FUNZIONALITA">
                <column name="RUOLO" primaryKey="true" required="true" type="VARCHAR" size="31">
                        <platform-column name="oracle" type="VARCHAR2" size="31"/>
                </column>
                <column name="FUNZIONALITA" primaryKey="true" required="true" type="VARCHAR" size="127">
                        <platform-column name="oracle" type="VARCHAR2" size="127"/>
                </column>
                <foreign-key name="SYS_C00150329" foreignTable="AUTH_FUNZIONALITA">
                        <reference local="FUNZIONALITA" foreign="CODICE"/>
                </foreign-key>
                <foreign-key name="SYS_C00150330" foreignTable="AUTH_RUOLO">
                        <reference local="RUOLO" foreign="NOME"/>
                </foreign-key>
        </table>
</database>
[auth-slave-001] - PostgreSqlDatabasePlatform - Running alter sql:
CREATE TABLE "AUTH_RUOLO_FUNZIONALITA"(
    "RUOLO" VARCHAR(31) NOT NULL,
    "FUNZIONALITA" VARCHAR(127) NOT NULL,
    PRIMARY KEY ("RUOLO", "FUNZIONALITA")
);
ALTER TABLE "AUTH_RUOLO_FUNZIONALITA"
    ADD CONSTRAINT "SYS_C00150329" FOREIGN KEY ("FUNZIONALITA") REFERENCES "AUTH_FUNZIONALITA" ("CODICE");
ALTER TABLE "AUTH_RUOLO_FUNZIONALITA"
    ADD CONSTRAINT "SYS_C00150330" FOREIGN KEY ("RUOLO") REFERENCES "AUTH_RUOLO" ("NOME");

[auth-slave-001] - PullService - Pull data received from auth-master:auth-master-000:auth-master-000. 26 rows and 26 batches were processed

chenson

2014-09-15 10:02

administrator   ~0000576

Does it fail consistently? Does the table exist?

hrk

2014-09-15 10:40

reporter   ~0000577

Last edited: 2014-09-15 10:46

View 2 revisions

I'm sorry, I couldn't comment without reopening the bug.

It fails consistently, even after completely purging and recreating the entire schema under postgres.

Using the commandline client to auto-complete, I can see that the table exists:
mntr_scorte=# select * from mntr_auth.
mntr_auth."AUTH_FUNZIONALITA"
mntr_auth."AUTH_LOG"
mntr_auth."AUTH_RUOLO"
mntr_auth."AUTH_RUOLO_FUNZIONALITA"
mntr_auth."AUTH_UTENTE"
mntr_auth."AUTH_UTENTE_CENTRALE"
mntr_auth."AUTH_UTENTE_RUOLO"
mntr_auth."CARATTERISTICHE_CENTRALE"
mntr_auth."DATI_CENTRALE"
mntr_auth."DECODIFICA_LOG"
mntr_auth."DECODIFICA_NAVE"
mntr_auth."DECODIFICA_NOTIFICA"
mntr_auth."DECODIFICA_PROVENIENZA"
mntr_auth."FORNITORE"
mntr_auth."MAPPA_IDV_ARRIVO"
mntr_auth."NAVE"
mntr_auth."QRTZ_BLOB_TRIGGERS"
mntr_auth."QRTZ_CALENDARS"
mntr_auth."QRTZ_CRON_TRIGGERS"
mntr_auth."QRTZ_FIRED_TRIGGERS"
mntr_auth."QRTZ_JOB_DETAILS"
mntr_auth."QRTZ_LOCKS"
mntr_auth."QRTZ_PAUSED_TRIGGER_GRPS"
mntr_auth."QRTZ_SCHEDULER_STATE"
mntr_auth."QRTZ_SIMPLE_TRIGGERS"
mntr_auth."QRTZ_SIMPROP_TRIGGERS"
mntr_auth."QRTZ_TRIGGERS"
mntr_auth."RICEVENTE"
mntr_auth."SOTTOSCRIZIONE"
mntr_auth."STORICO_FLUSSO_CBS"
mntr_auth.sym_channel
mntr_auth.sym_conflict
mntr_auth.sym_data
mntr_auth.sym_data_data_id_seq
mntr_auth.sym_data_event
mntr_auth.sym_data_gap
mntr_auth.sym_extract_request
mntr_auth.sym_file_incoming
mntr_auth.sym_file_snapshot
mntr_auth.sym_file_trigger
mntr_auth.sym_file_trigger_router
mntr_auth.sym_grouplet
mntr_auth.sym_grouplet_link
mntr_auth.sym_incoming_batch
mntr_auth.sym_incoming_error
mntr_auth.sym_load_filter
mntr_auth.sym_lock
mntr_auth.sym_node
mntr_auth.sym_node_channel_ctl
mntr_auth.sym_node_communication
mntr_auth.sym_node_group
mntr_auth.sym_node_group_channel_wnd
mntr_auth.sym_node_group_link
mntr_auth.sym_node_host
mntr_auth.sym_node_host_channel_stats
mntr_auth.sym_node_host_job_stats
mntr_auth.sym_node_host_stats
mntr_auth.sym_node_identity
mntr_auth.sym_node_security
mntr_auth.sym_outgoing_batch
mntr_auth.sym_parameter
mntr_auth.sym_registration_redirect
mntr_auth.sym_registration_request
mntr_auth.sym_router
mntr_auth.sym_sequence
mntr_auth.sym_table_reload_request
mntr_auth.sym_transform_column
mntr_auth.sym_transform_table
mntr_auth.sym_trigger
mntr_auth.sym_trigger_hist
mntr_auth.sym_trigger_router
mntr_auth.sym_trigger_router_grouplet
mntr_scorte=# select * from mntr_auth.

hrk

2014-09-15 10:51

reporter   ~0000579

Manually performing the DDL written in the log gives me a "relation already exists" error in psql. The same error (already existing) happens with the constraints.

chenson

2014-09-15 10:51

administrator   ~0000580

What batch is failing? Insert into auth_utente_ruolo? Does that table exist? Not sure what to tell you. Do you have cyclical foreign keys?

hrk

2014-09-15 10:55

reporter   ~0000581

Editing the record in sym_outgoing_batch setting status to 'OK' and starting again Symmetric causes the same error with another existing table, QUARTS_SIMPLE_TRIGGERS. The only clue I can get is that in the error log the name of the table is lowercase whereas in the DDL and in the database it's UPPERCASE.

I'll wait for 3.6.8, maybe the workaround from the first post isn't enough.

chenson

2014-09-15 12:42

administrator   ~0000582

Can you try this version?

http://snapshots.repository.codehaus.org/org/jumpmind/symmetric/symmetric-assemble/3.7.0-SNAPSHOT/symmetric-assemble-3.7.0-20140915.150648-8-server.zip

hrk

2014-09-15 12:44

reporter   ~0000583

I will be able to test it in 14-15 hours from now.

hrk

2014-09-16 04:00

reporter   ~0000584

Good morning, we're almost there! I started w/ the 3.7.0-snapshot after performing an uninstall in both PostgreSQL and Oracle, cleaning out PostgreSQL's schema. I removed the "workaround" and performed the initial setup, open-registration and reload-node commands.

Every DDL appears to have worked fine, however an issue arised when inserting values. I guess it's a different bug so I will open a new one.

tl;dr: 3.7.0-snapshot w/o workaround completed successfully the DDL initialization. Bug is fixed.

Related Changesets

SymmetricDS: master d0c62a99

2014-09-15 09:13:30

chenson

Details Diff
0001965: Initial load uses wrong case on Oracle to PostgreSQL table creation.
0001965
mod - symmetric-db/src/main/java/org/jumpmind/db/platform/AbstractDatabasePlatform.java Diff File

Issue History

Date Modified Username Field Change
2014-09-15 06:08 hrk New Issue
2014-09-15 08:36 chenson Note Added: 0000573
2014-09-15 08:36 chenson Note Edited: 0000573 View Revisions
2014-09-15 08:46 hrk Note Added: 0000574
2014-09-15 08:47 hrk Note Added: 0000575
2014-09-15 09:13 chenson Status new => resolved
2014-09-15 09:13 chenson Fixed in Version => 3.6.8
2014-09-15 09:13 chenson Resolution open => fixed
2014-09-15 09:13 chenson Assigned To => chenson
2014-09-15 10:00 chenson Changeset attached => SymmetricDS trunk r8689
2014-09-15 10:00 chenson Changeset attached => SymmetricDS 3.6 r8690
2014-09-15 10:02 chenson Note Added: 0000576
2014-09-15 10:40 hrk Note Added: 0000577
2014-09-15 10:40 hrk Status resolved => feedback
2014-09-15 10:40 hrk Resolution fixed => reopened
2014-09-15 10:45 hrk Status feedback => assigned
2014-09-15 10:46 hrk Note Edited: 0000577 View Revisions
2014-09-15 10:51 hrk Note Added: 0000579
2014-09-15 10:51 chenson Note Added: 0000580
2014-09-15 10:55 hrk Note Added: 0000581
2014-09-15 12:40 chenson Target Version => 3.6.8
2014-09-15 12:42 chenson Note Added: 0000582
2014-09-15 12:44 hrk Note Added: 0000583
2014-09-16 04:00 hrk Note Added: 0000584
2014-09-17 18:01 chenson Status assigned => closed
2015-07-30 21:49 chenson Changeset attached => SymmetricDS master d0c62a99