View Issue Details

IDProjectCategoryView StatusLast Update
0004254SymmetricDSBugpublic2020-02-14 12:44
ReporterEngy Assigned Topmarzullo  
Priorityhigh 
Status closedResolutionfixed 
Product Version3.10.5 
Target Version3.10.10Fixed in Version3.10.10 
Summary0004254: Multi-master configuration with 3 nodes doesn't work
DescriptionMulti-master configuration with 3 nodes doesn't work. Periodic 1 second report to console:

[master-3] - PushService - Push data sent to master:2:2
[master-3] - PushService - Could not communicate with master:2:2 at http://PC:31415/sync/master-2 because: java.net.SocketException: Software caused connection abort: recv failed
[master-3] - PushService - Push data sent to master:2:2
[master-3] - PushService - Could not communicate with master:2:2 at http://PC:31415/sync/master-2 because: java.net.SocketException: Software caused connection abort: recv failed
[master-3] - PushService - Push data sent to master:2:2
[master-3] - PushService - Could not communicate with master:2:2 at http://PC:31415/sync/master-2 because: java.net.SocketException: Software caused connection abort: recv failed
[master-3] - PushService - Push data sent to master:2:2
[master-3] - PushService - Could not communicate with master:2:2 at http://PC:31415/sync/master-2 because: java.net.SocketException: Software caused connection abort: recv failed
[master-3] - PushService - Push data sent to master:2:2
[master-3] - PushService - Could not communicate with master:2:2 at http://PC:31415/sync/master-2 because: java.net.SocketException: Software caused connection abort: recv failed
[master-3] - PushService - Push data sent to master:2:2
[master-3] - PushService - Could not communicate with master:2:2 at http://PC:31415/sync/master-2 because: java.net.SocketException: Software caused connection abort: recv failed
[master-3] - PushService - Push data sent to master:2:2
[master-3] - PushService - Could not communicate with master:2:2 at http://PC:31415/sync/master-2 because: java.net.SocketException: Software caused connection abort: recv failed

=======
After some time the error changes to:

[master-3] - PushService - Push data sent to master:2:2
[master-3] - PushService - Could not communicate with master:2:2 at http://PC:31415/sync/master-2 because: java.net.SocketException: Software caused connection abort: recv failed
java.net.SocketException: Software caused connection abort: recv failed
        at java.net.SocketInputStream.socketRead0(Native Method)
        at java.net.SocketInputStream.socketRead(Unknown Source)
        at java.net.SocketInputStream.read(Unknown Source)
        at java.net.SocketInputStream.read(Unknown Source)
        at java.io.BufferedInputStream.fill(Unknown Source)
        at java.io.BufferedInputStream.read1(Unknown Source)
        at java.io.BufferedInputStream.read(Unknown Source)
        at sun.net.www.http.HttpClient.parseHTTPHeader(Unknown Source)
        at sun.net.www.http.HttpClient.parseHTTP(Unknown Source)
        at sun.net.www.protocol.http.HttpURLConnection.getInputStream0(Unknown Source)
        at sun.net.www.protocol.http.HttpURLConnection.getInputStream(Unknown Source)
        at java.net.HttpURLConnection.getResponseCode(Unknown Source)
        at org.jumpmind.symmetric.transport.http.HttpOutgoingTransport.readResponse(HttpOutgoingTransport.java:320)
        at com.jumpmind.symmetric.console.remote.m.readResponse(RemoteStatusHttpOutgoingTransport.java:62)
        at org.jumpmind.symmetric.service.impl.AbstractService.readAcks(AbstractService.java:295)
        at org.jumpmind.symmetric.service.impl.PushService.pushToNode(PushService.java:211)
        at org.jumpmind.symmetric.service.impl.PushService.execute(PushService.java:167)
        at org.jumpmind.symmetric.service.impl.NodeCommunicationService$1.run(NodeCommunicationService.java:517)
        at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)
        at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
        at java.lang.Thread.run(Unknown Source)
[master-3] - PushService - Push data sent to master:2:2
[master-3] - PushService - Could not communicate with master:2:2 at http://PC:31415/sync/master-2 because: java.net.SocketException: Software caused connection abort: recv failed
java.net.SocketException: Software caused connection abort: recv failed
        at java.net.SocketInputStream.socketRead0(Native Method)
        at java.net.SocketInputStream.socketRead(Unknown Source)
        at java.net.SocketInputStream.read(Unknown Source)
        at java.net.SocketInputStream.read(Unknown Source)
Steps To Reproduce1) Fresh SymmetricDS pro installation
2) Create Master node with H2 database and table DB1
3) Create Local Node with H2 database and table DB2
4) Create Local Node with H2 database and table DB3

... or sample configuration included
Tagsregistration

Relationships

related to 0004269 closedpmarzullo Multi-master configuration with 3 nodes doesn't work 

Activities

Engy

2020-01-21 10:15

reporter  

cfg.zip (162,999 bytes)

Engy

2020-01-28 11:06

reporter   ~0001681

Just checked that exactly same simple configuration is working with version 3.8.42 and 3.9.18 and is broken in 3.10.*

Related Changesets

SymmetricDS: 3.10 f51edec0

2020-01-31 10:51:54

Philip Marzullo

Details Diff
0004254: Multi-master configuration with 3 nodes doesn't work Affected Issues
0004254
mod - symmetric-core/src/main/java/org/jumpmind/symmetric/service/IParameterService.java Diff File
mod - symmetric-core/src/main/java/org/jumpmind/symmetric/service/impl/ParameterService.java Diff File
mod - symmetric-core/src/main/java/org/jumpmind/symmetric/service/impl/PushService.java Diff File
mod - symmetric-core/src/main/java/org/jumpmind/symmetric/service/impl/RegistrationService.java Diff File
mod - symmetric-core/src/main/java/org/jumpmind/symmetric/service/impl/RouterService.java Diff File
mod - symmetric-core/src/main/java/org/jumpmind/symmetric/service/impl/TriggerRouterService.java Diff File
mod - symmetric-core/src/test/java/org/jumpmind/symmetric/service/impl/MockParameterService.java Diff File

Issue History

Date Modified Username Field Change
2020-01-21 10:15 Engy New Issue
2020-01-21 10:15 Engy File Added: cfg.zip
2020-01-28 11:06 Engy Note Added: 0001681
2020-01-29 08:08 elong Assigned To => pmarzullo
2020-01-29 08:08 elong Status new => confirmed
2020-01-29 08:08 elong Product Version 3.11.3 => 3.10.5
2020-01-29 08:08 elong Target Version => 3.10.10
2020-01-31 09:24 pmarzullo Project SymmetricDS Pro => SymmetricDS
2020-01-31 10:50 pmarzullo Tag Attached: registration
2020-01-31 10:51 pmarzullo Relationship added related to 0004269
2020-01-31 10:56 pmarzullo Status confirmed => resolved
2020-01-31 10:56 pmarzullo Resolution open => fixed
2020-01-31 10:56 pmarzullo Fixed in Version => 3.10.10
2020-01-31 11:00 Changeset attached => SymmetricDS 3.10 f51edec0
2020-02-14 12:44 elong Status resolved => closed