View Issue Details

IDProjectCategoryView StatusLast Update
0004358SymmetricDSBugpublic2020-05-26 12:37
ReportergwilmerAssigned Topmarzullo 
Priorityhigh 
Status closedResolutionfixed 
Product Version3.11.7 
Target Version3.11.9Fixed in Version3.11.9 
Summary0004358: JNA error from systemd on RHEL
DescriptionJNA error while trying to run SymmetricDS as a service on RHEL 7.7

Linux version info:

cat /etc/os-release
NAME="Red Hat Enterprise Linux Server"
VERSION="7.7 (Maipo)"
ID="rhel"
ID_LIKE="fedora"
VARIANT="Server"
VARIANT_ID="server"
VERSION_ID="7.7"
PRETTY_NAME=RHEL
ANSI_COLOR="0;31"
CPE_NAME="cpe:/o:redhat:enterprise_linux:7.7:GA:server"
HOME_URL="https://www.redhat.com/"
BUG_REPORT_URL="https://bugzilla.redhat.com/"
REDHAT_BUGZILLA_PRODUCT="Red Hat Enterprise Linux 7"
REDHAT_BUGZILLA_PRODUCT_VERSION=7.7
REDHAT_SUPPORT_PRODUCT="Red Hat Enterprise Linux"
REDHAT_SUPPORT_PRODUCT_VERSION="7.7"

Steps To Reproduce - Install linux as a service through installer.
 - Attempt to start, or specify status of SymmetricDS service.

sudo systemctl start SymmetricDS.service
Job for SymmetricDS.service failed because the control process exited with error code. See "systemctl status SymmetricDS.service" and "journalctl -xe" for details.
[REDACTED@REDACTED ~]$ sudo systemctl status SymmetricDS.service
‚óŹ SymmetricDS.service - Database Synchronization
  Loaded: loaded (/usr/lib/systemd/system/SymmetricDS.service; enabled; vendor preset: disabled)
  Active: failed (Result: exit-code) since Thu 2020-04-16 12:23:53 PDT; 10s ago
 Process: 2427 ExecStart=/usr/bin/java -jar /app/symmetricds/lib/symmetric-wrapper.jar start (code=exited, status=1/FAILURE)
Apr 16 12:23:53 REDACTED java[2427]: at java.lang.ClassLoader$NativeLibrary.load(Native Method)
Apr 16 12:23:53 REDACTED java[2427]: at java.lang.ClassLoader.loadLibrary0(ClassLoader.java:1946)
Apr 16 12:23:53 REDACTED java[2427]: at java.lang.ClassLoader.loadLibrary(ClassLoader.java:1828)
Apr 16 12:23:53 REDACTED java[2427]: at java.lang.Runtime.load0(Runtime.java:810)
Apr 16 12:23:53 REDACTED java[2427]: at java.lang.System.load(System.java:1088)
Apr 16 12:23:53 REDACTED java[2427]: at com.sun.jna.Native.loadNativeDispatchLibraryFromClasspath(Native.java:947)
Apr 16 12:23:53 REDACTED systemd[1]: SymmetricDS.service: control process exited, code=exited status=1
Apr 16 12:23:53 REDACTED systemd[1]: Failed to start Database Synchronization.
Apr 16 12:23:53 REDACTED systemd[1]: Unit SymmetricDS.service entered failed state.
Apr 16 12:23:53 REDACTED systemd[1]: SymmetricDS.service failed.
[REDACTED@REDACTED ~]$

Tagssym/sym_service

Relationships

related to 0004353 closedelong SymmetricDS Pro Unable to run as a service on RHEL because Java absolute path 
related to 0004380 closedpmarzullo SymmetricDS Systemd installation: need to specify -Djava.io.tmpdir on command line in systemd control file 
related to 0004381 closedpmarzullo SymmetricDS Systemd installation: need to specify -Djava.io.tmpdir on command line in systemd control file 
related to 0004382 closedpmarzullo SymmetricDS Initd installation: need to specify -Djava.io.tmpdir on command line in initd file 
related to 0004383 closedpmarzullo SymmetricDS Initd installation: need to specify -Djava.io.tmpdir on command line in initd file 

Activities

elong

2020-04-21 10:46

developer   ~0001705

1. The stack trace is cut off, please send output of "sudo systemctl status SymmetricDS.service -l"

2. Try running command line yourself: /usr/bin/java -jar /app/symmetricds/lib/symmetric-wrapper.jar start

elong

2020-04-21 10:46

developer   ~0001706

Can you attach the logs/install.log?

pmarzullo

2020-04-21 10:46

developer   ~0001707

I was able to reproduce the java specification (not absolute patch) in the service specification file.

I was not able to reproduce the JNA issue (I edited the service file to specify absolute path of java, and rebooted). It came up just fine.
I am running on 7.8 (I did install 7.7, but then did an update to get up to date tools and stuff, but it ended up updating to 7.8).

Really can use those logs before I remove virtual machine and reinstall 7.7 to test there.

Issue History

Date Modified Username Field Change
2020-04-21 10:46 elong New Issue
2020-04-21 10:46 elong Issue generated from: 0004353
2020-04-21 10:46 elong Note Added: 0001705
2020-04-21 10:46 elong Note Added: 0001706
2020-04-21 10:46 elong Note Added: 0001707
2020-04-21 10:46 elong Relationship added related to 0004353
2020-04-21 10:46 elong Tag Attached: sym/sym_service
2020-04-21 10:46 elong Project SymmetricDS Pro => SymmetricDS
2020-04-21 10:46 elong Reporter elong => gwilmer
2020-05-22 13:35 elong Relationship added related to 0004380
2020-05-22 13:36 elong Relationship added related to 0004381
2020-05-22 13:36 elong Relationship added related to 0004382
2020-05-22 13:36 elong Relationship added related to 0004383
2020-05-22 13:36 elong Assigned To => pmarzullo
2020-05-22 13:36 elong Status new => resolved
2020-05-22 13:36 elong Resolution open => fixed
2020-05-22 13:36 elong Fixed in Version => 3.11.9
2020-05-22 13:36 elong Target Version => 3.11.9
2020-05-26 12:37 elong Status resolved => closed