View Issue Details

IDProjectCategoryView StatusLast Update
0004553SymmetricDSBugpublic2020-09-23 16:34
Reporterpmarzullo Assigned Topmarzullo  
Prioritynormal 
Status closedResolutionfixed 
Product Version3.12.3 
Target Version3.12.4Fixed in Version3.12.4 
Summary0004553: Transforms break deletes when transforming primary key column and not capturing old data as specified in trigger
DescriptionWhen a trigger is set up to not capture old data, and a transform is created that transforms a primary key column, the value of the primary key column ends up being null instead of the value that the transform set it to because the transforms set the value to the old value of a NewAndOldValue object.
Then the TransformWriter takes that old value from the NewAndOldValue object ignores it because there are no oldSourceValues because the trigger did not capture old data.
Steps To Reproduce1. Set up trigger to not capture old data.
2. Set up transform, with a primary key set to a "bsh" type of transform, with the expression set to "return currentValue;".
3. Cause a delete to be captured.
4. Target record will not be deleted.

The staging file should have a null value for the primary key value.
Tagstransformation

Relationships

related to 0004552 closedpmarzullo Transforms break deletes when transforming primary key column and not capturing old data as specified in trigger 

Activities

There are no notes attached to this issue.

Issue History

Date Modified Username Field Change
2020-09-16 16:43 pmarzullo New Issue
2020-09-16 16:43 pmarzullo Status new => assigned
2020-09-16 16:43 pmarzullo Assigned To => pmarzullo
2020-09-16 16:43 pmarzullo Tag Attached: transformation
2020-09-16 16:43 pmarzullo Relationship added related to 0004552
2020-09-16 16:43 pmarzullo Status assigned => resolved
2020-09-16 16:43 pmarzullo Resolution open => fixed
2020-09-16 16:43 pmarzullo Fixed in Version => 3.12.4
2020-09-23 16:34 admin Status resolved => closed